云安全日报210603:Ubuntu Linux内核发现执行任意代码和拒绝服务漏洞,需要尽快升级

来源:TechWeb.com.cn2021-06-03 20:28:38

Ubuntu是一个以桌面应用为主的Linux操作系统。它是一个开放源代码的自由软件,提供了一个健壮、功能丰富的计算环境,既适合家庭使用又适用于商业环境。Ubuntu为全球数百个公司提供商业支持。

6月2日,Ubuntu发布了安全更新,修复了Ubuntu Linux内核发现执行任意代码和拒绝服务漏洞。以下是漏洞详情:

漏洞详情

来源:https://ubuntu.com/security/notices/USN-4979-1

1.CVE-2020-25670 严重程度:中

在 Linux 内核中发现了一个漏洞,其中 llcp_sock_bind() 中的引用计数泄漏导致释放后使用,这可能会导致权限提升。

2.CVE-2020-25671 严重程度:中

在 Linux 内核中发现了一个漏洞,其中 llcp_sock_connect() 中的引用计数泄漏导致 use-after-free 可能导致权限升级。

3.CVE-2020-25672 严重程度:中

Linux内核在llcp_sock_connect中发现内存泄漏漏洞

4.CVE-2020-25673 严重程度:中

在 Linux 内核中发现了一个漏洞,其中 llcp_sock_connect() 中的非阻塞套接字导致泄漏并最终挂断系统。

5.CVE-2021-28660 严重程度:中

从 5.11.6 开始,Linux 内核中的drivers/staging/rtl8188eu/os_dep/ioctl_linux.c 中的rtw_wx_set_scan 允许写入超出->ssid[] 数组的末尾。注意:从 kernel.org 版本的角度来看,CVE ID 通常不用于驱动程序/暂存/*(未完成的工作);然而,系统集成商可能会遇到与他们自己的客户群相关的驱动程序/分期问题。

受影响产品和版本

上述漏洞影响Ubuntu 18.04 LTS, Ubuntu 16.04 ESM, Ubuntu 14.04 ESM

解决方案

可以通过将系统更新为以下软件包版本来解决此问题:

Ubuntu 18.04:

linux-image-4.15.0-1100-gcp - 4.15.0-1100.113

linux-image-4.15.0-1092-kvm - 4.15.0-1092.94

linux-image-4.15.0-144-generic-lpae - 4.15.0-144.148

linux-image-gcp-lts-18.04 - 4.15.0.1100.118

linux-image-oracle-lts-18.04 - 4.15.0.1072.82

linux-image-4.15.0-1103-snapdragon - 4.15.0-1103.112

linux-image-virtual - 4.15.0.144.131

linux-image-snapdragon - 4.15.0.1103.106

linux-image-4.15.0-144-generic - 4.15.0-144.148

linux-image-4.15.0-1072-oracle - 4.15.0-1072.80

linux-image-aws-lts-18.04 - 4.15.0.1103.106

linux-image-generic - 4.15.0.144.131

linux-image-4.15.0-1103-aws - 4.15.0-1103.110

linux-image-4.15.0-1115-azure - 4.15.0-1115.128

linux-image-kvm - 4.15.0.1092.88

linux-image-azure-lts-18.04 - 4.15.0.1115.88

linux-image-4.15.0-144-lowlatency - 4.15.0-144.148

linux-image-generic-lpae - 4.15.0.144.131

linux-image-lowlatency - 4.15.0.144.131

Ubuntu 16.04:

linux-image-gke - 4.15.0.1100.101

Available with UA Infra or UA Desktop

linux-image-oracle - 4.15.0.1072.60

Available with UA Infra or UA Desktop

linux-image-4.15.0-1100-gcp - 4.15.0-1100.113~16.04.1

Available with UA Infra or UA Desktop

linux-image-4.15.0-144-lowlatency - 4.15.0-144.148~16.04.1

Available with UA Infra or UA Desktop

linux-image-4.15.0-1103-aws - 4.15.0-1103.110~16.04.1

Available with UA Infra or UA Desktop

linux-image-lowlatency-hwe-16.04 - 4.15.0.144.140

Available with UA Infra or UA Desktop

linux-image-4.15.0-1115-azure - 4.15.0-1115.128~16.04.1

Available with UA Infra or UA Desktop

linux-image-generic-hwe-16.04 - 4.15.0.144.140

Available with UA Infra or UA Desktop

linux-image-4.15.0-144-generic - 4.15.0-144.148~16.04.1

Available with UA Infra or UA Desktop

linux-image-gcp - 4.15.0.1100.101

Available with UA Infra or UA Desktop

linux-image-oem - 4.15.0.144.140

Available with UA Infra or UA Desktop

linux-image-virtual-hwe-16.04 - 4.15.0.144.140

Available with UA Infra or UA Desktop

linux-image-azure - 4.15.0.1115.106

Available with UA Infra or UA Desktop

linux-image-aws-hwe - 4.15.0.1103.94

Available with UA Infra or UA Desktop

linux-image-4.15.0-1072-oracle - 4.15.0-1072.80~16.04.1

Available with UA Infra or UA Desktop

Ubuntu 14.04:

linux-image-4.15.0-1115-azure - 4.15.0-1115.128~14.04.1

Available with UA Infra or UA Desktop

linux-image-azure - 4.15.0.1115.88

Available with UA Infra or UA Desktop

查看更多漏洞信息 以及升级请访问官网:

https://ubuntu.com/security/cve

责任编辑:JayJay

标签: Linux Ubuntu 云安全 漏洞 拒绝服务攻击

相关文章

要闻

原创

最新

取消